How to create an Uberlisk
Open the Data Editor and...
Go to the Units Tab:
(Note: If you do not have a tab open that is mentioned in this guide you can open it by selecting it from the Data Type drop-down in the upper lefthand corner of the Data Editor)
·	Create a duplicate of Unit Ultralisk (Right-click on the Unit and select Duplicate Object; do not check anything)
·	Rename the duplicate to Uberlisk and click Suggest so that the ID changes to match the name. (This is done by double-clicking on the Object itself.)

Go to the Actors Tab:
·	Create a duplicate of the Actor Ultralisk (Can be found under Unit->GenericUnitBase->Not Doodad if your view is set to Folders)
·	Rename the duplicate to Uberlisk and click Suggest. 
·	On the right hand side make the following changes to this actor:
·	unitName = Uberlisk (found in the Token portion at the top)
·	Sounds= 
·	Index: Attack, Value: Ultralisk_Attack 
·	Index: Pissed, Value: Ultralisk_Pissed 
·	Index: Ready, Value: Ultralisk_Ready 
·	Index: What, Value: Ultralisk_What 
·	Index: Yes, Value: Ultralisk_Yes

Go to the Models Tab:
·	Create a duplicate of Model Ultralisk
·	Rename the duplicate to Uberlisk and click Suggest
·	Make the following changes:
·	Scale Maximum = 1, 1, 1 (X, Y, Z)
·	Scale Minimum = 1, 1, 1 (X, Y, Z)
(You want your Uberlisk to be beefed up :p)
At this point you should be able to place your new unit on the map.
Test this by going to the Map Editor and trying to drop an Uberlisk on it.
NOTE: If you try to do this and all that shows up is an orb make sure that you have your new Model selected under the Model area of your Uberlisk Actor. Also verify your new Uberlisk Model has a proper .m3 file selected under the Model area (it should be Ultralisk.m3).
Now to really continue we need to make our Movers for the tentacles that we are going to be applying to our Uberlisk's back. 
Go to the Movers Tab:
·	Right-click on the left hand side and click Add Object.
·	Give the new object the following setting:
·	Name: UberliskRangeWeapon, be sure to Suggest for the ID
·	Mover Type: Missile
·	Add another Object and give it the following settings:
·	Name: UberliskRangeWeaponRetract, use Suggest for the ID.
·	Mover Type: Missile
Select the UberliskRangeWeapon Mover we just made and double-click the Motion Phases + option on the right-hand side.
·	Create the following Movers:
(To add these click the Add Value button (file_0.wmf

) on the right hand side. Also items marked by a * have a note below this section about them.)
·	Driver = Throw
Acceleration = 50
Speed = 50
Max Speed = 200
Ignore Terrain = Enabled
Outro = BlendBase: 0.2; StopBase: 0.4
Rotation Launch Actor Type = Supplied
Throw Rotation Type = Look At Target
Throw Vector = 0,-1,6 (X, Y, Z)
·	Driver = Guidance
Acceleration = 140
Max Speed = 200
Ignore Terrain = Enabled
Turn Type = Revert To Up
*Orientation (i.e. YawPitchRoll) = 180
*Orientation Acceleration (i.e. YawPitchRollAccel) = 1440
·	Driver = Guidance
Acceleration = 140
Speed = 12
Max Speed = 200
Ignore Terrain = Enabled
Turn Type = Revert To Up
Rotation Launch Type = Look At Target 2D
Rotation Launch Actor Type = Supplied
*Orientation (i.e. YawPitchRoll) = MAX
* = NOTE: To properly set the Orientation Settings you will need to go into Raw Data View (Do this by clicking View->View Raw Data). Near the Bottom you will see CMoverMissile_MotionPhases_YawPitchRoll and CMoverMissile_MotionPhases_YawPitchRollAccel. Double-click on YawPitchRoll and if there are not already 3 variables here add them to make 3 and then set them to 0, 180, MAX (respectively from top to bottom in the list). Double-click on YawPitchRollAccel and do the same thing except use the settings 0, 1440, 0 respectively from top to bottom. Exit out of Raw Data View when your done.
Select the UberliskRangeWeaponRetract Mover and double-click the Motion Phases + option on the right-hand side.
·	Create the following Movers:
·	Driver = Throw
Acceleration = 50
Speed = 50
Max Speed = 200
Ignore Terrain = Enabled
Outro = BlendBase: 3.0; StopBase: 3.0
Timeout = 3
Throw Rotation Type = Look At Target
Throw Vector = 0.0, 0.0, 0.1 (X, Y, Z)
·	Driver = Throw
Acceleration = 50
Speed = 50
Max Speed = 200
Ignore Terrain = Enabled
Outro = BlendBase: 6.0; StopBase: 6.0
Timeout = 3
Throw Rotation Type = Look At Target
Throw Vector = 0.0, 0.0, 0.2 (X, Y, Z)
·	Driver = Guidance
Acceleration = 40
Speed = 8.5
Max Speed = 200
Ignore Terrain = Enabled
Tracking = Actual
Timeout = 0.25
Now that we have our Movers your going to want to create your Effects for Damage. 
Go to the Effects Tab:
·	Using Add Object create FIVE new Effects using the following settings: 
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskRangeU
·	UberliskRangeU2
·	UberliskRangeU3
·	UberliskRangeU4
·	UberliskRangeU5
·	Effect Type: Effect Damage
·	Based On: DU_WEAP
·	Make the following changes to each of the new Effects:
·	Amount = 100
·	Death = Blast
·	Kind = Ranged
Now we need to create Units that will be the representatives for our Spine Scrawlers. 
Go to the Units Tab:
·	Using Add Object create FIVE new Units  using the following settings: 
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskRangeLMWeapon
·	UberliskRangeLM2Weapon
·	UberliskRangeLM3Weapon
·	UberliskRangeLM4Weapon
·	UberliskRangeLM5Weapon
·	Based On: Default Settings (Projectile)
·	Object Family: Melee
·	Object Type: Projectile
·	Make the following changes to each of the new Units:
·	Movement - Mover: UberliskRangeWeapon
Now we are going to make the Effects for the launching of the tentacle itself.
Go to the Effects Tab:
·	Using Add Object create FIVE new Effects using the following settings: 
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskRangeLM
·	UberliskRangeLM2
·	UberliskRangeLM3
·	UberliskRangeLM4
·	UberliskRangeLM5
·	Effect Type: Launch Missile
·	Based On: Default Effect (CEffectLaunchMissile)
·	Make the following changes to each of the new Effects:
·	Flags = Point Fallback, Return, Validate Ability, Weapon
·	Movers + = UberliskRangeWeapon
·	Return Delay = 0.1750
·	Return Movers + = UberliskRangeWeaponRetract
·	Impact Effect = They repective UberliskRangeU for each of these i.e. for UberliskRangeLM select UberliskRangeU and for UberliskRangeLM2 select UberliskRangeU2, etc.
·	Ammo Unit: They respective UberliskRangeLMWeapon for each Effect.

Next we are going to make the weapons that we will be attaching to our Unit later on. 
Go to the Weapons Tab:
·	Using Add Object create FIVE new Weapons using the following settings: 
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskRange
·	UberliskRange2
·	UberliskRange3
·	UberliskRange4
·	UberliskRange5
·	Weapon Type: Legacy
·	Based On: CWeaponLegacy
·	Make the following changes to each of the new Effects:
·	Allowed Movement = Moving
·	Arc = 360
·	Backswing = 0
·	Damage Display Effect = Once again use the respective UberliskRangeU for each weapon.
·	Damage Point = 0.25 (subtract .05 for each weapon after the first on; i.e UberliskRange2 will be .20)
·	Effect = Use the respective UberliskRangeLM for each weapon.
·	Icon = Assets\Textures\btn-upgrade-zerg-seismicspines.dds
·	Legacy Options = Can Retarget While Channeling, Keep Channeling, No Deceleration
·	Minimum Scan Range = 8
·	Options = Hidden, Continuous Scan, Display Cooldown
·	Period = 1
·	Range = 7
·	Target Filters = Required: Visible; Excluded: Missile, Stasis, Dead, Hidden, Invulnerable 
(Note: To set this either double-click on the State for the specified Type until it is listed as specified or right-click in the State field to set the value. All Types not mentioned should be showing a State of Allowed.) 
Now comes the fun part as we are going to go through the steps to create all the needed Actors to create our working Spine Scrawlers on our Uberlisks back.
Go to the Actors Tab:
Creating Attachment Points
First things first we need to create some new Attachment Point Actors as the Ultralisk Model is somewhat limited on Attachment Points. 
·	Go under Site Operation (Attachment)-> CActorSiteOpAttach (Unnamed)-> Not Doodad and look for an Actor call SOpAttachTarget. 
·	Right click on SOpAttachTarget and create THREE duplicates of it.
·	Change the names to the following (Make sure to select Suggest to change the ID's):
·	SOpAttachTarget1
·	SOpAttachTarget7
·	SOpAttachTarget8 
·	Actor Type: Site Operation (Attachment)
·	Based On: CActorSiteOpAttach
Note: Have to uncheck Defines Default Values to set this.
·	Make the following change to each of the new Actors:
·	Attachment Query + = Target (followed by the number for each respective target i.e. for Target1 use the number 1 and for Target7 use the number 7, etc. Note that this is placed in the Index field.)
Ok now we are going to go through the grueling process of creating all the Actors for the Spine Crawler and the actual attaching of it to our Uberlisk. This will require 20 seperate Actors (FOUR for each of the FIVE Spine Crawlers we are attaching) so try and keep up. :p
Creating Launch Sites:
·	Using Add Object create FIVE new Actors using the following settings:
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskSpineCrawlerTentacleLaunchSite
·	UberliskSpineCrawlerTentacle2LaunchSite
·	UberliskSpineCrawlerTentacle3LaunchSite
·	UberliskSpineCrawlerTentacle4LaunchSite
·	UberliskSpineCrawlerTentacle5LaunchSite
·	Actor Type: Site
·	Based On: CActorSite
·	Doodad Type: Not Doodad
·	Make the following change to each of the new Actors:
·	Host + = Subject: ::scope.Tentacle; Scope: Implicit; Actor: Implicit; Effect: (None)
Creating Attack Missiles:
·	Using Add Object create FIVE new Actors using the following settings:
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskRangeAttackMissile
·	UberliskRangeAttackMissile2
·	UberliskRangeAttackMissile3
·	UberliskRangeAttackMissile4
·	UberliskRangeAttackMissile5
·	Actor Type: Missile
·	Based On: GenericTentacleMissile (Unnamed)
·	Doodad Type: Not Doodad
·	Make the following change to each of the new Actors:
·	Unit Name = (Select the Respective UberliskRangeLMWeapon for each one)
READ THIS BEFORE GOING ON!
-----------------------------------------
A few notes about Events. Events (file_1.wmf

) are created by right-clicking the left portion of the Object Event screen and selecting Add Event. Terms (file_2.wmf

) are added by right-clicking on the Event and selecting Add Term. Actions (file_3.wmf

) are automatically created when a new Event is created. You simply have to edit the Actions to match what is listed below. When looking at these Events below they are shown how they will look on the left hand side of the Object Events screen after entering them. 
For most Events you would change the Msg Type and anything after that is most likely a Source Name. If you see an (*) after a Msg Type that means the Source Name is (None) and whatever is after it is the Sub Name (i.e. Effect.*.Return is a Msg Type.Source Name.Sub Name).
Actions can be confusing but for the most part they are the same setup as Events. The beginning is the Msg Type followed by a Name and usually Properties and Flags for the Action. A good example of this would be "AnimPlay Main Back PlayForever" which is the Msg Type, Name, Animation Properties, and Flag (note for most things that require a Name is just something made up and if you don't have a Name that is specified you can just click the Customize button to the right of the Name box and add it).
-----------------------------------------
·	Events +: Add the following to each one (keep the ones that are currently there):
·	Event: UnitBirth
	Action: AnimPlay Main Birth
·	Event: ActorCreation
	Action: RefSet Name= ::scope.UberliskRangeAttackMissileScope, 	Source= ::Self
·	Event: SupporterDestruction
	Action: AnimPlay Death Death
·	Event: Effect.*.Return
	Action: AnimPlay Main Back PlayForever
·	Event: MotionPhaseStart
	Term: MotionPhase
	Action: RefSet Target= ::Supporter, Name= TentacleAttack(add a 2-5 	here for the respective Actors), Source= ::Self
·	Event: ActorDesctruction
	Action: Signal Target= ::Supporter, Name= TentacleRetracted
 Your Events should look like this when your done:
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·	Host Return + = Subject: UberliskSpineCrawlerTentacle(add 2-5 for the respective Actors), Scope: Target, Actor: Find, Effect: (Select the repective UberliskRangeLM for each one.)
·	Host Supporter + = Subject: UberliskSpineCrawlerTentacle(add 2-5 for the respective Actors), Scope: Caster, Actor: Find, Effect: (Select the repective UberliskRangeLM for each one.)
·	Model = Invisble
·	Remove + = Add the follow to each:
·	Event: UnitBirth
Action: AnimBracketStart Lifetime Birth Stand
Note: You will have to click the Add Value button in the Remove box and then click the Add Value button in the Terms box so you can properly set the Event (UnitBirth).
Should look like this when done:
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Creating the Spine Crawler Tentacles:
The next five actors are a bit tricky to make properly. If someone else can explain how to get the Effects that start with Signal.*.TentacleRetracted to show without doing this let me know.  For now do the following.
·	Find the Actor Spine Crawler and create FIVE duplicates of it (found under Unit->Zerg Building->Not Doodad if you use the folder view).
·	Double-click the duplicates to make the following changes:
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskSpineCrawlerTentacle
·	UberliskSpineCrawlerTentacle2
·	UberliskSpineCrawlerTentacle3
·	UberliskSpineCrawlerTentacle4
·	UberliskSpineCrawlerTentacle5
·	Actor Type: Model
·	Based On: ModelAddition
·	Make the following change to each of the new Actors:
·	Go into Raw Data View and for each Actor and right-click on the unitName token in the upper right area and Remove it; then turn off Raw Data View.
·	Animation Blend Time: -1
·	Event Sounds +: Remove eveything from here.
·	Events +:
·	Remove all but the following from the list:
·	Event: UnitBirth.SpineCrawler(change this to Uberlisk)
Action: Create
·	Event: ActorCreation
Action: AnimGroupApply Burrow
·	Event: WeaponStart.SpineCrawler(change this to the respective UberliskRange).AttackStart
Term: AnimPlaying Burrow 
Action: AnimClear Burrow
·	Event: WeaponStart.SpineCrawler(change this to the respective UberliskRange).AttackStart
Action: AnimPlay Attack Attack PlayForever
·	Event: WeaponStop.SpineCrawler(change this to the respective UberliskRange).AttackStop 
Action: AnimClear Attack
·	Event: Signal.*.TentacleRetracted 
Action: AnimClear Attack
·	Event: Signal.*.TentacleRetracted 
Action: RefClear TentacleAttack(add 2-5 for the respective Actors)
·	Event: Signal.*.TentacleRetracted
Term: ValidateUnit SpineCrawler(This term can be removed.)
Action: AnimPlay AttackEnd Attack,End
·	Add the following to Events:
·	Event: ActorCreation
Action: AnimBracketStart BSD Birth Stand Death
·	Event: ActorOrphan
Action: Destory
·	Event: AnimBracketState.*.AfterClosing
Term: AnimName BSD
Action: Destory
Once all that is said in done your Events should look something like this:
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·	Host Site Operations + = We are going to specify the Attachment location for each Spine Crawler. It does not matter which Tentacle you apply these to but you need to use the following attachment points (one for each Tentacle): SOpAttachHead, SOpAttachTarget, SOpAttachTarget1, SOpAttachTarget7, and SOpAttachTarget8.
·	Hosted Attachment + =  Name: TentacleAttack(add 2-5 for each respective Actor); Attachment Method: Weapon
·	Model = Spine Crawler
·	Remove + = Remove everything from here.
·	Scale =  0.6
Creating the Spine Attack:
·	Using Add Object create FIVE new Actors using the following settings:
·	Names: (Make sure to select Suggest to change the ID's)
·	UberliskSpineAttack
·	UberliskSpineAttack2
·	UberliskSpineAttack3
·	UberliskSpineAttack4
·	UberliskSpineAttack5
·	Actor Type: Action
·	Based On: GenericAttack
·	Doodad Type: Not Doodad
·	Make the following change to each of the new Actors:
·	Impact Effect =  (Use respective UberliskRangeU for each one.)
·	Launch Effect = (Use respective UberliskRangeLM for each one.)
·	Damage Attachment Query + = Overhead|Center (To do this double-click on the option and then under Methods there is a Filter type. Set this to Direct and then select Overhead from the drop-down. Select Center from the Fallback drop-down.)
·	Impact Attachment Query + = Target|Center
·	Impact Map + = Change the Follow:
·	Index: None, Sound: SpineCrawler_AttackImpact
·	Index: Flesh, Model Reaction: SpineCrawler Attack Impact Reaction Flesh
·	Index: LightArmor, Model Reaction: Light Armor Target Impact
·	Index: Metal, Model Reaction: Metal Target Impact
·	Impact Site Ops + = SOpAttachHarness SOpForwardLaunchGuide
·	Lanuch Assets + = Sound: SpineCrawler_AttackLaunch
·	Launch Attachment Query + = Overhead|Center
·	LaunchSite = UberliskSpineCrawlerTentacle(add 2-5 for the respective Actors)LaunchSite
·	Launch Site Ops + = SOpAttachOverhead
·	Missile = UberliskRangeAttackMissile(add 2-5 for rescpetive Actors)
Now that we are finally finished with all that all we need to do is change some stuff on our Uberlisk Unit.
Go to the Units Tab:
·	Select the Uberlisk we created at the beginning and add the following:
·	Weapons + = Add the following using the Add Value button:
·	UberliskRange
·	UberliskRange2
·	UberliskRange3
·	UberliskRange4
·	UberliskRange5 
	Note: You can keep the Ultralisk - Kaiser Blades and Ultralisk - Head Attack if you want.
·	You may also want to make the following change but it is not needed:
·	Life Regeneration Rate = 60
That should do it. Add your Uberlisk to your map as well as some enemy baddies and try it out!
I will see about adding the info on the Death Nova ability (the effect that kills everything around the Uberlisk upon death) at a later time.





